Front wiper delay - Chevy Trax Forum
 
Thread Tools
post #1 of 2 Old 06-12-2017, 02:02 PM Thread Starter
Junior Member
 
Join Date: Jun 2017
Posts: 1
(Thread Starter)
Front wiper delay

I have a 2014 LTD. my wiper delay doesn't seem to be working. I have also noticed every time I put my ignition lights on the wipers come on themselves. Always doing a 3 sweep of the screen before stopping halfway. Has anyone come across this problem. I think it's my wiper motor but them coming on straight away is confusing me.
Chevy is offline  
post #2 of 2 Old 06-14-2017, 09:44 AM
Senior Member
 
beeguz's Avatar
 
Join Date: Jun 2015
Location: Northeast
Posts: 592
I have seen that problem before but it was on a camaro and a corvette.

Its the circuit board that runs the wiper motor, on the corvette it was caused by the board getting wet.
beeguz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Trax Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield wiper arms? tmbldwn Chevy Trax General Discussion 5 01-01-2017 01:03 PM
Small port cover on right side front bumber Aaron Miller Appearance & Body 11 10-08-2016 10:14 AM
Non GM Wiper Blades replacement? lordphilippe Appearance & Body 10 08-01-2016 02:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome