MyLink Issue - Chevy Trax Forum
 
Thread Tools
post #1 of 4 Old 01-01-2017, 07:39 PM Thread Starter
Junior Member
 
Join Date: Jan 2017
Posts: 1
(Thread Starter)
Angry MyLink Issue

I had driven my 2015 Trax to run earns today and had no issue with the MyLink at the beginning. (Well it was alway sluggish to start from day one.) After starting my Trax and backing up(camera worked) the MyLink display looked like it was going to start up but it would freeze on the start up screen. After about a minute it would shut down (go black) and try to start up again, without any success. I have taken my 2015 Trax in for all the recalls within the last 3 weeks. Has anyone else had or have this problem?
frustrated is offline  
post #2 of 4 Old 01-02-2017, 10:43 AM
Senior Member
 
beeguz's Avatar
 
Join Date: Jun 2015
Location: Northeast
Posts: 574
I do think there are a few threads here with my link and radio problems, I would take it back tell them the radio isn't working,( you want the radio replaced.)

Some have had updates done, it did not repair the problem, I think when they do an update its just to put you off hoping you will not come back.

I had that instance with Toyota they told me noting was wrong with my radio, later on when I talked to someone who worked in the parts department off site, he told me the problem I was having was an everyday problem.

They just wanted me to go away, I did go away from Toyota and that dealer who sells multiple brands, never to return.
beeguz is offline  
post #3 of 4 Old 01-22-2017, 10:06 PM
Senior Member
 
Join Date: Apr 2014
Posts: 707
Before you take it back do some research on the dealer you plan to go to, some just aren't as help as they should be and from what I heard they're not nearly as good as say Toyota dealers.

Keep us posted on how things go.
James is offline  
 
post #4 of 4 Old 01-23-2017, 10:47 AM
Senior Member
 
beeguz's Avatar
 
Join Date: Jun 2015
Location: Northeast
Posts: 574
Don't get me started on Toyota dealers as far as my experience with Toyota they said if they didn't see my problem it didn't exist.

Then talking to the guy in the parts department, off site, he told me he ordered at least 10 units like mine a day.
beeguz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Trax Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth/Mic Issue = HELP! Joe Ranieri Electronics, Audio And Lighting 4 04-13-2017 12:40 PM
Brake assist issue? tmbldwn Engines and Technical Discussion 9 08-26-2016 10:58 AM
2015 Trax with a possible tranny issue Mfphill66 Introductions 21 06-25-2016 09:22 PM
Keyless Entry Issue Dagoon Electronics, Audio And Lighting 6 06-03-2016 04:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome