Trax turbo problems - Chevy Trax Forum
Reply
 
Thread Tools
post #1 of 41 Old 12-31-2018, 03:57 PM Thread Starter
Senior Member
 
Join Date: Feb 2017
Location: springfield,ohio
Posts: 117
(Thread Starter)
Trax turbo problems

Anybody have troubles with thier turbo charger? Well I think that is what's eating my oil that the dealership says I am imagining things it still full of oil I am so frustrated I wish I could pay it off and take it to the junkyard and have it crushed. I think I would have so much joy from it. Maybe I need to go to another dealership.
mackman is offline  
post #2 of 41 Old 01-01-2019, 12:03 AM
Senior Member
 
Join Date: Sep 2015
Posts: 206
If the oil is still full, why do you think the turbo is eating oil?

Jeff
2018 Trax LT AWD
2015 Trax LS AWD Sold
Flyinfool is offline  
post #3 of 41 Old 01-01-2019, 04:53 PM Thread Starter
Senior Member
 
Join Date: Feb 2017
Location: springfield,ohio
Posts: 117
(Thread Starter)
I really don't know I just think I am getting some bull from dealership I checked the oil level 4 times in 2 different locations but that is not the current issue it doesn't rev beyond 3,000 rpms I am so tired of the issues I am not sure just seem 1+1=3 it idles great and it doesn't smoke as I see it sits. Just seems like after I drive it smells of burnt oil and I had thought of oil ingestion of the turbo now it may have stopped working.

Last edited by SkipD; 01-02-2019 at 06:46 PM.
mackman is offline  
 
post #4 of 41 Old 01-02-2019, 12:50 PM
Senior Member
 
Join Date: Sep 2015
Posts: 206
If it will not rev past 3,000 then that is an issue that is easy to demonstrate to the dealer. Something is not right and if it is under warranty they should fix it. If the dealer says that a 3,000 RPM limit is normal, then you really need to go to a different dealer.

Jeff
2018 Trax LT AWD
2015 Trax LS AWD Sold
Flyinfool is offline  
post #5 of 41 Old 01-02-2019, 02:25 PM
Senior Member
 
Traxy's Avatar
 
Join Date: Sep 2017
Location: Magnetic Hill, New Brunswick Canada
Posts: 1,244
Send a message via AIM to Traxy Send a message via MSN to Traxy Send a message via Yahoo to Traxy
Quote:
Originally Posted by mackman View Post
I really don't know I just think I am getting some bull from dealership I checked the oil level 4 times in 2 different locations but that is not the current issue it doesn't rev beyond 3,000 rpms I am so tired of the issues I am not sure just seem 1+1=3 it idles great and it doesn't smoke as I see it sits. Just seems like after I drive it smells of burnt oil and I had thought of oil ingestion of the turbo now it may have stopped working.
It won't rev passed 3000 in park or neutral if that's when your checking it. Just get the torque pro lite app from google store and a 10$ bluetooth OBDII port adaptor and check boost yourself . It's cheap, simple to use and gives you peace of mind. Hand you can use it on any vehicle, so can help family and friends too. I couldn't live without it.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Never drive faster than your guardian angel can fly!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Last edited by SkipD; 01-02-2019 at 06:47 PM.
Traxy is online now  
post #6 of 41 Old 01-02-2019, 05:24 PM Thread Starter
Senior Member
 
Join Date: Feb 2017
Location: springfield,ohio
Posts: 117
(Thread Starter)
Good idea Traxy never thought of that i have a good code reader with live data need to take pics and that will have plenty of ammo. Nice idea Thanks Traxy. Yes i hope the warranty covers it though it should have never happened to begin with.
mackman is offline  
post #7 of 41 Old 01-02-2019, 05:28 PM Thread Starter
Senior Member
 
Join Date: Feb 2017
Location: springfield,ohio
Posts: 117
(Thread Starter)
Yes i did something stupid that actually paid off so was to buy the extended warranty but this is going to test it. The factory warranty bumper to bumper gone. I love driving it but this testing i can't trust it anymore all the miles i put on it i thought were reliable enjoyable miles sadly.....Poooooffffff reality kicks in.Just missed the factory powertrain warranty by 7,000 miles.

Last edited by SkipD; 01-02-2019 at 06:48 PM.
mackman is offline  
post #8 of 41 Old 01-03-2019, 01:52 PM Thread Starter
Senior Member
 
Join Date: Feb 2017
Location: springfield,ohio
Posts: 117
(Thread Starter)
Hey Tracy it's burning oil under load and the boost is it supposed to go positive or go lower negative? Everything checks out within the dongle app specs all green check marks just boost I am not sure about.
mackman is offline  
post #9 of 41 Old 01-03-2019, 03:19 PM
Senior Member
 
Traxy's Avatar
 
Join Date: Sep 2017
Location: Magnetic Hill, New Brunswick Canada
Posts: 1,244
Send a message via AIM to Traxy Send a message via MSN to Traxy Send a message via Yahoo to Traxy
You should have positive boost under load. Make sure you are reading PSI and not HG. My highest under load going up a steep hill in 6th was +9.1 PSI at idle vacuum should read around -9 PSI. I know there's a GM Tech on here and he should know what is really normal and what the waste gate is set at. The numbers I gave you are mine and not sure they are the norm.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Never drive faster than your guardian angel can fly!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716
Traxy is online now  
post #10 of 41 Old 01-03-2019, 04:30 PM Thread Starter
Senior Member
 
Join Date: Feb 2017
Location: springfield,ohio
Posts: 117
(Thread Starter)
It just stays in the -.07 then up 0 and the engine is bogged down like it's gasping for air which i have a sneaking idea it is conclusion my opinion bad turbo let them find it ans hope the catalytic converter is not clogged with oil and the engine was not damaged to badly with the low oil level. I am just a fountain of certainty that this will be the last one for me. Going else where for another car might even think about those hyundai's or the toyota's i have been hearing about lol no foreign cars for me hahaha......
mackman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Trax Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
What problems have you experienced with your Chevrolet Trax James Chevy Trax General Discussion 209 11-13-2019 02:01 PM
Trax problems Tom Armes Introductions 12 03-30-2019 01:16 PM
2015 Chevy Trax with multiple problems joe360x Chevy Trax General Discussion 0 08-15-2018 12:03 AM
1.6L Turbo for TRAX? Kooper Chevy Trax General Discussion 6 01-24-2015 09:24 PM
GM announces Trax LTZ Turbo for down under Sidetraxed Chevy Trax General Discussion 17 10-29-2014 03:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome