2015 Trax Turbo issue - Chevy Trax Forum
 
Thread Tools
post #1 of 3 Old 05-11-2019, 06:06 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 1
(Thread Starter)
2015 Trax Turbo issue

New to this forum, this is my first post so thanks for welcoming me aboard. I bought my Trax brand new in 2015. Never had any issues with it until a month ago. Got the timely oil changes, always synthetic oil and never had any technical issues until recently. My car was bucking while driving fairly easy in first and second gears. Each gear would rev up to 6500rpm's before switching into the next. Highway driving was awful, as I heard a cranking noise if I held my foot on the pedal to accelerate but would stop if I took my foot off the gas or feathered it. I could only get it to go up to 75mph but if I let my foot off the gas the bucking would start and I'd drop in mph's like an anchor. It turns out my oil light would come on when I was nearing the end of my trip. I would put 3 quarts in and I would be able to keep driving. When I accelerated onto the highway, I had extremely thick clouds of white smoke where I couldn't even see the cars behind me. This also happened when I would rev high on side roads when trying to speed up. I brought to mechanic and he said he needed to replace the turbo. So I paid $1400 for the turbo replacement, spark plugs, a full synthetic oil change plus labor. And the day after I picked it up from mechanic, I'm back at square one. Oil light came on this morning. I have 2 years of payments left, so I can't just move on from it. Sorry for the long detailed post, but please help if you can!! Thank you!!
Killbillvolume3 is offline  
post #2 of 3 Old 05-11-2019, 07:11 PM
Senior Member
 
Traxy's Avatar
 
Join Date: Sep 2017
Location: Magnetic Hill, New Brunswick Canada
Posts: 1,075
Send a message via AIM to Traxy Send a message via MSN to Traxy Send a message via Yahoo to Traxy
I would take it back to the mechanic which was suppose to fix it. After all you paid for the repair it should be repaired.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Never drive faster than your guardian angel can fly!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716
Traxy is online now  
post #3 of 3 Old 07-19-2019, 01:51 AM
Junior Member
 
Montkun's Avatar
 
Join Date: Jul 2019
Location: Pittsburgh, PA, USA
Posts: 26
Sounds like you have a problem with the oil supply lines, not sure whether it's inbound or outbound as the source. Should have recognized that problem immediately if they actually replaced the turbo as they should have, since they should have to disconnect them to remove the old one.

Sent from my BND-L34 using Tapatalk
Montkun is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Trax Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Trax turbo problems mackman Engines and Technical Discussion 27 01-19-2019 04:48 PM
2016 Trax with a noise maybe from the turbo and A/C acting up daltontate Chevy Trax General Discussion 2 10-24-2018 11:26 AM
2015 Trax with a possible tranny issue Mfphill66 Introductions 21 06-25-2016 09:22 PM
1.6L Turbo for TRAX? Kooper Chevy Trax General Discussion 6 01-24-2015 08:24 PM
GM announces Trax LTZ Turbo for down under Sidetraxed Chevy Trax General Discussion 17 10-29-2014 02:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome