Chevy Trax Forum - Reply to Topic
Thread: Blower doesn't work Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Chevy Trax Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-12-2019 07:49 PM
semch1
Blower fan

I bought a 2015 last year, at about 8 months #4 on fan stopped...took it to the dealer this June and they wanted $300 to fix even tho I had an extended warranty.I said no....picked up my car and #4 was working ....drove it a month and now all of them do not work. Any ideas?
07-02-2019 06:32 PM
Eric s Hello thanks for the quick answer, i checked the fuses next to the motor , they seem fine, ill check the others, didnt realise there were more...if ok will look at the blower connections.
It stopped working alltogether. I dont know if aircon is affected also, without blower there is no air coming out....
07-02-2019 10:48 AM
Traxy Doesn't work at all? Or only on high speed? Only the F3 40amp fuse for the fan motor is under the bonnet. HVAC fan control fuse is to the left of the steering behind the card holder. Motor control F12 10amp and relay #4 are for the blower fan.




Check your owner's manual in case yours is different.



It may also be the resistor network. ( GM#95018066 ).



Blower fan ( GM#95920148 )



It could also be the blower motor connector that corroded or melted and lost contact.
07-02-2019 07:31 AM
Eric s
Blower doesn't work

I'm new to this forum, i just bought a 2014 trax, all seemed fine until the blower decided to stop working. I already checked every fuse under the bonnet but they seem fine....could it be something else then simply the blower giving out? And is that hard to replace? Hope someone knows......

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome