Chevy Trax Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So we finally broke down and got my wife a newer vehicle so she hopefully wouldnt have anymore car problems for a while. Now im beginning to regret it. Its a 2015 Chevy Trax and today she came home and the fan was running on high after she shut off the car. I let it run for about 5 minutes longer and when it still didnt turn off I decided to hook up my code scanner to it. It had no engine lights on and no messages in the display but i figured id do it anyhow. I got a P0299. So I look it up and it says turbo boost is low. Now she has been complaining that it acts as though it doesnt have much power when she first leaves work. Ive yet to be able to replicate her problem when I drive it. Had no idea it had this code because there was no check engine light on and the light does work when you turn on the key prior to start. After all this I unhooked the negative battery terminal to shut off the fan. Decided to buy a relay for the fan hoping that a stuck relay is the problem with the fan. I tapped on the relay a couple times before putting the terminal back on. Im at a complete loss here. She said no lights came on while she was driving it and the reservoir was still where it should be so I dont believe it was overheating and caused the fan to go into a safe mode. Can someone with more knowledge then me on these vehicles please help. We are trying to get with the dealer tomorrow but she has to drive it in the morning to work because i just started a new job today and I have to have my car tomorrow.
 
1 - 1 of 1 Posts
Top