Chevy Trax Forum banner
21 - 35 of 35 Posts

·
Registered
Joined
·
6 Posts
Fixed*
I found out how to fix this issue. Turn the vehicle completely off, open and close your door so the radio shuts down. Then wait about 30-60 seconds and press and hold the middle power button until the radio turns on. This will turn on just the radio, go into the time/date setting, turn off the automatic time and set the clock to what you need. I had to do then after trying the whole shabang of car in park on/ car in park in aux. but this fixes the issue
 

·
Registered
Joined
·
5 Posts
According to manual the clock will set itself in automatic mode when it finds a GPS satellite (This can take up to 5 minutes with cloud covered skies ) Otherwise to set it manually you have to first disable automatic then you can select manual setting. This is out of the 2018 Trax manual. Unfortunately there is no pictorial step-by-step.

View attachment 3363
My display doesn’t show automatic at all. 2018 trax
 

·
Registered
Joined
·
1 Posts
Many tries... The last try worked.. Shutting off everything for over a minute, then using the radio power button only. Don't turn the key on..
It will give you the option to turn automatic off..
Then you can set the clock.
 

·
Registered
Joined
·
1 Posts
Fixed*
I found out how to fix this issue. Turn the vehicle completely off, open and close your door so the radio shuts down. Then wait about 30-60 seconds and press and hold the middle power button until the radio turns on. This will turn on just the radio, go into the time/date setting, turn off the automatic time and set the clock to what you need. I had to do then after trying the whole shabang of car in park on/ car in park in aux. but this fixes the issue
[/QUOTE]
This fixed it for me, Thank you!
 

·
Registered
Joined
·
3 Posts
According to manual the clock will set itself in automatic mode when it finds a GPS satellite (This can take up to 5 minutes with cloud covered skies ) Otherwise to set it manually you have to first disable automatic then you can select manual setting. This is out of the 2018 Trax manual. Unfortunately there is no pictorial step-by-step.

View attachment 3363
According to manual the clock will set itself in automatic mode when it finds a GPS satellite (This can take up to 5 minutes with cloud covered skies ) Otherwise to set it manually you have to first disable automatic then you can select manual setting. This is out of the 2018 Trax manual. Unfortunately there is no pictorial step-by-step.

View attachment 3363
I don't pay for onstar, so don't think that is the problem. I have tried to set the clock, with the car on, and also with the car off as people recommended on here. I have a new radio/clock put in, and still doesn't work. clock is very slow or going backwards. I did the 12 and the 24 hour setting. Nothing is working. ???
 

·
Registered
Joined
·
2 Posts
According to manual the clock will set itself in automatic mode when it finds a GPS satellite (This can take up to 5 minutes with cloud covered skies ) Otherwise to set it manually you have to first disable automatic then you can select manual setting. This is out of the 2018 Trax manual. Unfortunately there is no pictorial step-by-step. View attachment 3363
Mine does not display he Auto .Set time is up top and only 3 options
 

·
Registered
Joined
·
2 Posts
I found that while In park, I turned my key to the auxillary position and tried to change the time from there. Found I was able to turn off auto time set. Once I switched it to manual setting I was able to change everything fine. I hope this helps some other people out there.
What the freak is auxiliary position and how’d it ou get there/ that
 

·
Registered
Joined
·
1 Posts
I found this thread and had the same issue in my 2019, but low and behold no updates or answers for years! So if you also found this thread google searching after daylight savings time, allow me to update how I got it to work: Turn the vehicle completely off, so that the radio is completely off. Then, I turned on the console but not the vehicle by pressing the middle power button. From there, it made the auto time set option available where it had been missing before. Turned that off and was able to set time manually!
You sir, are smarter than the average bear and a lifesaver. Your instructions worked perfectly! Please feel free to patch yourself on the back and quote at your own brilliance.
 
21 - 35 of 35 Posts
Top