Chevy Trax Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter · #1 ·
I finally got around to loading my BNR Racing tune. I will say it added a bunch of power to my little trax. Ive got to do some data logging and send it to them to fine tune. But it seems to have woke up the 1.4 engine. The BNR is not a canned tune. You send them your stock tune and they send you back a tune based of of your stock tune, them you put the custom tune in and drive around some and do a couple of full power pulls while data logging and they fine tune it and you should have a pretty good custom tune. They use the autocal 3 hand held tuner.
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #2 ·
I also installed a BNR Waste gate actuator and it will hold 20 lbs of boost. I don't know what power gains I have but it is much quicker than it was. I like it.
 

·
Administrator
Joined
·
2,444 Posts
You probably void the warranty, this engine isn't designed for 20PSI of pressure. Did you also change the tune to match this actuator? It's the ECM that controls the actuator.
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #4 ·
You are right, you can't use this actuator without a tune. You will get an over boost code. I have a Bad News Racing tune to go with the waste gate so all is well. And I will only loose warranty if I get caught with the waste gate and tune in the car. But this thing is fun to drive now. If I can keep my foot out of it maybe I won't tear up anything. I'm pretty handy with a wrench and can fix most stuff.
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #5 ·
Just got my torque pro going. The boost @ idle is 17.5 and will hit 23 lbs. Thats some serious boost. The car runs great.
 

·
Administrator
Joined
·
2,444 Posts
Something wrong here you must have something confused. At idle you should have vacuum. Are you sure you are set for PSI?
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #7 ·
Forgive me for being a moron. I haven't used this app before. When you first turn in on it says boost but as soon as you start it it goes to vacuum. I was just trying it out in the drive way. I didn't realize that as soon as you start driving in gear it turns to boost. I will try it out later and see what it is. Sorry.
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #8 · (Edited)
It came a winter storm and haven't fooled with the Trax for a few days. Got the app figured out and made an adjustment to the way the boost is calculated. Part throttle is at 15 to 16 PSI of boost and can hit 20 when WFO. The tune is set between 20 and 23 pounds of boost. If it goes over 23 I will get a code. Has not happened yet. I'm at 2 turns of pre load on the waste gate. The car has a lot of power at part throttle and runs great. I had to replace the coil pack due to a random mis fire under load. I put an Axcell coil pack in I got new from Ebay for 60 bucks and free shipping. Took care of the problem. I'm happy with the way it runs and performs.
 
1 - 8 of 8 Posts
Top