Chevy Trax Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Greetings,
Each year I head to Florida for six months, I connect a battery conditioner to trickle charge the battery. Every year I come back the battery has no charge and each time I set it up before I leave I make sure the connections are correct and the conditioner is working properly. Does the car have some kind of sensor or is there a power draw that is not maintained with a 1 amp charger? Ant help would be appreciated. Car is stored in an enclosed garage in NY state.
 

·
Administrator
Joined
·
2,596 Posts
I do the same with no problem but I put it in transport mode where it draws very little current.

 

·
Registered
Trax 2019 LT AWD
Joined
·
17 Posts
For what it is worth I just watched a youtube video from MotorWeek | Goss’ Garage: Dead Battery and in the video it is recommended to use a "battery maintainer" not a "trickle charger" because the maintainer will turn off when the voltage is at the proper level then turn on again when needed (it servos in a feedback loop to control voltage level). The trickle charger just keeps sending charge (in a sense open-loop no feedback). In the video, it states not to use a trickle charger. I tried to just copy a link to the video but the video appears?

When I googled this all kinds of sites appear which confirm the above statement.
.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #5 ·
For what it is worth I just watched a youtube video from MotorWeek | Goss’ Garage: Dead Battery and in the video it is recommended to use a "battery maintainer" not a "trickle charger" because the maintainer will turn off when the voltage is at the proper level then turn on again when needed (it servos in a feedback loop to control voltage level). The trickle charger just keeps sending charge (in a sense open-loop no feedback). In the video, it states not to use a trickle charger. I tried to just copy a link to the video but the video appears?

When I googled this all kinds of sites appear which confirm the above statement.
.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #6 ·
Thanks for your reply. I am using a battery conditioner on each of two vehicles and the Trax is the problem one, it looks like I need to use the transport mode,
 
1 - 6 of 6 Posts
Top