Chevy Trax Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Just got wife anew trax and now after 24hrs it is throwing a o2 sensor code.

I have attached a screen shots of codesand freeze frame data ... any idea what I'm in for? Looks like it happened from a cold start.

Font Parallel Screenshot Rectangle Number


Product Font Rectangle Screenshot Number


Font Rectangle Screenshot Parallel Number
 

·
Super Moderator
Joined
·
2,318 Posts
Looking at this, I tend to think this vehicle has been sitting for a while. Clear all codes and take it for a good run, lets say 100 kms or a 60 mile run. Oxygen sensors tend to build up a residue over time if not used. Although yours seems to point to a burnt heater element on the second HO². Was it purchased as a GM optimum used vehicle? if so it is warrantied.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Traxy,

Went to take the car for a drive today and the code has cleared itself... I will be taking it by the dealer as the car still has some warranty left as it is at only 24k for review and I have to wait 2 weeks for service.

Thanks for your response...
 

·
Registered
Joined
·
15 Posts
I had a 2017 that did the same thing a day after I bought it. I ordered a new o2 sensor but before I could install it the code cleared itself. Just drive it for a few days before you go to the trouble of going to the dealer.
 

·
Registered
Joined
·
1 Posts
Good luck with that mate I have a Holden Trax and I've had intermittent engine lights related to fuel mixture imbalance changed everything apart from ECG which is next and it just keeps coming back!
 
1 - 6 of 6 Posts
Top