Chevy Trax Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
I have a 2015 Trax and I’ve had to replace the engine fan relay a couple times now. Stays running and drains battery after I turn it off. If I wiggle fuse it will stop. Fan comes on freezing cold days too...when it kicks in it dims my lights and bogs it down. Why does this keep happening?! Factory defect?
Anyone else have this issues?!
 

·
Super Moderator
Joined
·
2,272 Posts
You probably have a sticking fan relay. Replace the relay
 

·
Super Moderator
Joined
·
2,272 Posts
Did you replace the fan?
 

·
Registered
Joined
·
31 Posts
I'm experiencing the same thing right now. I just replaced the relay, we shall see.
 
  • Like
Reactions: Trixie

·
Registered
Joined
·
1 Posts
I have a 2015 Trax and I’ve had to replace the engine fan relay a couple times now. Stays running and drains battery after I turn it off. If I wiggle fuse it will stop. Fan comes on freezing cold days too...when it kicks in it dims my lights and bogs it down. Why does this keep happening?! Factory defect?
Anyone else have this issues?!
I started having this issue on my 2015 Trax this week (100,250 miles). Topped off coolant, had the battery replaced, drained again. I regularly drive 1-4 hours on the highway each week. Went to check relay this morning, battery's dead again. Will need a jump again and to drive a while to check if relay fixed the problem. Seems like I should stock up? I love my car, but is she at the end of her life?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
I started having this issue on my 2015 Trax this week (100,250 miles). Topped off coolant, had the battery replaced, drained again. I regularly drive 1-4 hours on the highway each week. Went to check relay this morning, battery's dead again. Will need a jump again and to drive a while to check if relay fixed the problem. Seems like I should stock up? I love my car, but is she at the end of her life?
There is a little black box on top of the cooling fan, at edge of good. It has a couple relays inside it. We replaced one of them and so far I haven’t had a problem. Just had to replace my battery as well and I replaced my other relay inside my fuse panel. Let me know if you need a pic.
 

·
Registered
Joined
·
1 Posts
This is happening to our 2015 Trax also, I bought a relay and a coolant temp sensor. We shall see if it works.
I have a 2015 Trax and I’ve had to replace the engine fan relay a couple times now. Stays running and drains battery after I turn it off. If I wiggle fuse it will stop. Fan comes on freezing cold days too...when it kicks in it dims my lights and bogs it down. Why does this keep happening?! Factory defect?
Anyone else have this issues?!
 

·
Registered
Joined
·
1 Posts
There is a little black box on top of the cooling fan, at edge of good. It has a couple relays inside it. We replaced one of them and so far I haven’t had a problem. Just had to replace my battery as well and I replaced my other relay inside my fuse panel. Let me know if you need a pic.
If you still happen to have that pic, I would greatly appit. Looks like I'm now having this issue and will need to replace my relay switch as well :-(
 

·
Registered
Joined
·
31 Posts
Follow up from 7 months ago. I replaced the fan relay and all has been good since. I bought an extra and threw it in the glove box.
 
1 - 11 of 11 Posts
Top