Chevy Trax Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Any ideas on the problem, new computer required? Checked all connections I could get to, battery out, cleaned everything. Code went away one day and came back when started next day. Anybody else have this code?
 

·
Registered
Joined
·
1,277 Posts
It looks like an internal self test by the ECM.

 

·
Registered
Joined
·
1,277 Posts
If the code is for internal memory test fail, it isn't going to get better. You can keep resetting the CEL and when it gets too annoying then you'll have to change the ECM. I've never had this problem and don't even know where it's at in the Trax. I may look that up later out of curiosity.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Just to give an update, pending fault engine light still happening. Theres a timer that resets so thats why the code returns the next day. Ive ordered a new control module, I have the tool and software to reprogram. Recently engine started misfiring, ended up pulling wngine coil and spark plugs, 3 of 4 wires were totally corroded at only 56k km. Replaced with new engine coil and mf sparkplugs, car starts and runs much smoother. It unfortunately didnt resolve the comuter code so working on replacing the module now. Car runs fine... just that pending fault and engine light continuing to pester me.. until the day it conks. Work in progress.

Stumped on ability to use a new programmed or used ecm and reprogrammed? if anyone has feedback on this its appreciated
 
1 - 6 of 6 Posts
Top