Chevy Trax Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2015 Chevy Trax LT and I have an issue. I went to my car after grocery shopping and my battery sounded like it was dying, no big deal, until the immobilizer dash light came on. I thought it was strange since my car was running and the light was staying on, but drove it home nonetheless to take care of it there. When I got home, I turned off my car and turned it back on, it still sounded like the battery was going soon, but the light didn't come on. Later that night I went out again, and the car wouldn't start altogether. After a jump start, it was running and the immobilizer light was back on. The next day, my car is dead when I'm leaving for work so I jump it again and the light is back on. I changed the battery in my chip key to see if that was a part of the problem but it hasn't seemed to work. My car still flashes that light what seems like every 5 or 6 times I turn it on, and I have to jump it like every 3 times I start it. Any thoughts on what's wrong?
 

·
Premium Member
Joined
·
34 Posts
Sounds to me like it's time to thoroughly test both the battery and the car's charging system. This is something that most folks are not equipped to do at home. I'd recommend a trip to your dealer.
 

·
Registered
Joined
·
228 Posts
I had issues with the immobilizer light on my 2015, there is/was a service bulletin to fix it. I did not have any other symptoms of battery issues, but the temps were around -20°F so the battery voltage may have been a bit low.

I was not able to find anything online about the issues with the immobilizer but my dealer did find something wrong that their computer could see but my code reader could not, and fixed it no charge under warranty.
 

·
Super Moderator
Joined
·
2,057 Posts
Batteries usually last about 7 years on average. But some may die prematurely depending on usage. I would start by replacing the battery.
 

·
Registered
Joined
·
115 Posts
This is my 2nd Minnesota winter with my '15 LT AWD. This light came on a couple of days ago. I left for work in the morning. Temperature on the infotainment screen said about -10F. I park outside with sun. Breezy. Used key to start the truck and let it run about 5 minutes. Temp around -6F when I left work. Immobilizer light was on for about 40 minutes of driving. Has not come on again.
 
1 - 5 of 5 Posts
Top