Chevy Trax Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi Everyone,

I have a 2015 Trax LT with 107,000 kms on it. Yesterday while we were out driving, the temp light came on. When we parked and checked it appeared the thermostat had given out according to our neighbour (mechanic with years of experience). So I replaced that last night, not a fun task with large hands, but we accomplished it. Now after starting it up, the temp light stays on still, and the engine idles very rough giving Code 84 on the dash. The radiator fan stays running the whole time with or without the A/C on, which also doesn't seem to want to cool or turn on. We double checked all the electrical connectors are tight and none were missed in reinstalling the thermostat.

Any suggestions on what to check next? Maybe the temp sensor itself?

Thank you,
Joe
 

·
Super Moderator
Joined
·
1,571 Posts
Code 84 is a reduced engine power. Did you clear the codes after changing the thermostat? Was it still full of coolant when the light came on?
3490
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thank you for the info Traxy!
It was full of coolant and we cleared codes afterwards too.
I spoke with a friend who works at a dealership close by, and he recommended to replace the engine coolant temp sensor on the water outlet. Hopefully that does the trick.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
All fixed. Coolant temp sensor and the code 84 is gone. The idle is normal and the engine temp light is out. Hope this helps someone else too. Thanks!
 
1 - 4 of 4 Posts
Top